Buses 16 & 18 will be combined on bus 18 for OMS & CHS (Possible Delays) 12/4/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Dec 05, 2024 - 05:12 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 04, 2024 - 13:43 EST
This incident affected: Transportation (Bus 16, Bus 18).