Sub Driver on Bus 18 - Expect possible delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted May 19, 2022 - 16:26 EDT
Investigating
We are currently investigating this issue.
Posted May 19, 2022 - 13:02 EDT
This incident affected: Transportation (Bus 18).