Buses 5 & 25 will be combined on bus 25 for OES
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 13, 2025 - 09:28 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 13, 2025 - 06:30 EST
This incident affected: Transportation (Bus 05, Bus 25).