Buses 16 & 22 are combined on bus 16 for CMS (Possible Delays) 4/24/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 24, 2024 - 17:05 EDT
Update
We are continuing to monitor for any further issues.
Posted Apr 24, 2024 - 13:33 EDT
Monitoring
Students who live on Ormand Rd will ride bus 9 for CMS & CHS/NGC
Posted Apr 24, 2024 - 13:29 EDT
This incident affected: Transportation (Bus 09, Bus 16, Bus 22).