Buses 5 & 49 will be combined on bus 49 for OES (Possible Delays) 3/25/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 05:49 EDT

Monitoring

Bus 49 will be 1st load
Bus 5 will be 2nd load
Posted Mar 25, 2025 - 13:47 EDT
This incident affected: Transportation (Bus 05, Bus 49).