Bus 5, 7, 14, 29, 31 & 44 has a sub driver (Possible Delays) 12/2/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Dec 03, 2024 - 05:27 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 02, 2024 - 14:00 EST
This incident affected: Transportation (Bus 05, Bus 07, Bus 14, Bus 29, Bus 31, Bus 44).