Bus 34 = Sub Driver, expect delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Oct 06, 2022 - 14:00 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 06, 2022 - 05:47 EDT
This incident affected: Transportation (Bus 34).