Bus 15 will be split between buses 3, 11, 29 & 31 for Bethany, CMS & CHS/NGC (Possible Delays) 4/15/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 17:09 EDT
Update
We are continuing to monitor for any further issues.
Posted Apr 15, 2024 - 15:53 EDT
Monitoring
Students who live on Henry Knob Rd & Knox Rd will ride bus 3
Students who live on Lloyd White, Whitesides, Windsong, Lilly Dr, Shepherd Ln & 1961 Hwy 55, Robinson Yelton & Crowders Creek Rd will ride bus 11
Students who live on Agony Acers Rd, Beamguard Rd, & Frontier will bus 31 for Bethany and bus 29 for CMS & CHS/NGC
Posted Apr 15, 2024 - 14:14 EDT
This incident affected: Transportation (Bus 15).