Bus 22 will be combined with buses 14(GES), 12(CMS) & 13(CHS/NGC) (Possible Delays) 4/16/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 05:41 EDT
Monitoring
Students who live on Ormand Rd will ride bus 9 for CMS & CHS/NGC
Posted Apr 16, 2024 - 13:23 EDT
This incident affected: Transportation (Bus 09, Bus 12, Bus 13, Bus 14, Bus 22).