Bus#7 - Has a sub driver today. Expect possible delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Nov 23, 2021 - 09:42 EST
Update
We are continuing to work on a fix for this issue.
Posted Nov 23, 2021 - 08:25 EST
Identified
Bus #4 will pick up Senate and Calhoun

Faulkner and Alexander

Faulkner and Westland

Bus #7 will pick up the remainder of the route

Bus #7 will be running 15 minutes behind
Posted Nov 23, 2021 - 08:23 EST
Investigating
We are currently investigating this issue.
Posted Nov 23, 2021 - 05:28 EST
This incident affected: Transportation (Bus 07).