Bus 49 will be split between buses 27 & 46 for OMS & CHS (Possible Delays)
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 09, 2024 - 09:23 EDT
Monitoring
The Landings will ride bus 27
The Bluffs will ride bus 46
Posted Sep 09, 2024 - 06:15 EDT
This incident affected: Transportation (Bus 27, Bus 46, Bus 49).