Bus 6, 14, 19 & 54 has a sub driver (Possible Delays) 1/6/26

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Jan 06, 2026 - 20:34 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 06, 2026 - 14:24 EST
This incident affected: Transportation (Bus 06, Bus 14, Bus 19, Bus 44).