Bus 4, 48, 49 & 53 has a sub driver (Possible Delays) 3/6/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 07, 2025 - 05:18 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 06, 2025 - 14:32 EST
This incident affected: Transportation (Bus 04, Bus 48, Bus 49, Bus 53).