Bus 1, 5, 16, 17, 23, 35, 42 & 48 has a sub driver (Possible Delays) 12/9/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Dec 09, 2024 - 09:25 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 09, 2024 - 06:17 EST
This incident affected: Transportation (Bus 01, Bus 05, Bus 16, Bus 17, Bus 23, Bus 35, Bus 42, Bus 48).