Buses 7 & 29 will be combined on bus 24 for CHS/NGC (Possible Delays) 4/26/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 26, 2024 - 15:11 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 26, 2024 - 12:32 EDT
This incident affected: Transportation (Bus 07, Bus 29).