Bus #2 = 508-1917 (#22)

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 22, 2023 - 17:16 EDT

Investigating

We are currently investigating this issue.
Posted Mar 22, 2023 - 14:10 EDT
This incident affected: Transportation (Bus 22).