Bus #6 = Sub Bus #49
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 06, 2022 - 17:10 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jan 06, 2022 - 13:53 EST
This incident affected: Transportation (Bus 06).