PowerSchool Performance Degraded
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Dec 01, 2021 - 16:28 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 01, 2021 - 13:42 EST
Investigating
We are currently investigating this issue.
Posted Dec 01, 2021 - 09:07 EST
This incident affected: PowerSchool (PowerSchool Admin, PowerSchool Student & Parent Portal, PowerSchool Teacher).