Bus #8 - Sub driver. Expect POSSIBLE delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted May 23, 2022 - 08:31 EDT
Investigating
We are currently investigating this issue.
Posted May 23, 2022 - 05:25 EDT
This incident affected: Transportation (Bus 08).