Bus #13 is broken down - Bus #13 will be on Bus#22
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 11, 2022 - 08:49 EST
Update
We are continuing to work on a fix for this issue.
Posted Jan 11, 2022 - 07:27 EST
Update
We are continuing to work on a fix for this issue.
Posted Jan 11, 2022 - 07:25 EST
Update
We are continuing to work on a fix for this issue.
Posted Jan 11, 2022 - 06:41 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Jan 11, 2022 - 06:39 EST
This incident affected: Transportation (Bus 13).