Bus 4, 6, 10, 15, 34 & 52 has a sub driver (Possible Delays) 2/14/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Feb 14, 2025 - 10:58 EST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Feb 14, 2025 - 06:17 EST
This incident affected: Transportation (Bus 04, Bus 06, Bus 10, Bus 15, Bus 34, Bus 52).