Bus #2 is spilt between Bus #1, Bus #3 and Bus #29 for Elementary. Middle School bus #2 is split between Bus #1, Bus #7 and Bus #29
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 13, 2022 - 17:27 EST
Update
We are continuing to investigate this issue.
Posted Jan 13, 2022 - 13:44 EST
Investigating
We are currently investigating this issue.
Posted Jan 13, 2022 - 13:43 EST
This incident affected: Transportation (Bus 02).