Bus 24 will be split between buses 18 & 30 for CHS/NGC (Possible Delays) 4/17/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 09:17 EDT
Monitoring
Students who live on Mountainview, Crosswind, All Stops in Timbers, All Stops on Charlotte Hwy will ride on bus 18
Students who live on Boulder, Liberty Hill, Fermont, Rockledge will ride on bus 30
Posted Apr 17, 2024 - 07:32 EDT
This incident affected: Transportation (Bus 18, Bus 24, Bus 30).