Bus 35 will be a 2nd load on bus 60 for CCES (Possible Delays) 3/31/26

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 31, 2026 - 17:29 EDT

Monitoring

Bus 60 will be 1st load
Bus 35 will be 2nd load
Posted Mar 31, 2026 - 13:42 EDT
This incident affected: Transportation (Bus 35, Bus 60).