BUS 3 AND BUS 21 WILL BE COMBINED FOR CHS and running late
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 09:26 EDT
Update
We are continuing to investigate this issue.
Posted Sep 28, 2022 - 08:44 EDT
Investigating
We are currently investigating this issue.
Posted Sep 28, 2022 - 07:13 EDT
This incident affected: Transportation (Bus 03, Bus 21).