Bus 34 will be split between buses 9 & 47 for LES and buses 4 & 47 for CMS & CHS (Possible Delays) 12/5/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Dec 05, 2024 - 09:20 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2024 - 06:06 EST
This incident affected: Transportation (Bus 04, Bus 09, Bus 34, Bus 47).