Bs #24 is on Bus #3 this morning
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 11, 2022 - 08:50 EST
Investigating
We are currently investigating this issue.
Posted Jan 11, 2022 - 06:12 EST
This incident affected: Transportation (Bus 24).