Bus #5 = Sub Driver, expect delays

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 22, 2023 - 17:15 EDT

Investigating

We are currently investigating this issue.
Posted Mar 22, 2023 - 13:41 EDT
This incident affected: Transportation (Bus 05).