Bus 3 & 16 has a sub driver (Possible Delays) 9/6/2024
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 06, 2024 - 11:29 EDT
Investigating
We are currently investigating this issue.
Posted Sep 06, 2024 - 06:03 EDT
This incident affected: Transportation (Bus 03, Bus 16).