Bus 49 will be split between buses 33 & 46 for OMS & CHS/NGC (Possible Delays)
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 19, 2024 - 05:39 EDT
Monitoring
The Landings will ride bus 33
The Bluffs will ride bus 46
Posted Apr 18, 2024 - 14:20 EDT
This incident affected: Transportation (Bus 33, Bus 46, Bus 49).