BUS 16 OMS IS RUNNING 5-10 MINUTES BEHIND
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 09:26 EDT
Update
We are continuing to investigate this issue.
Posted Sep 28, 2022 - 07:26 EDT
Investigating
We are currently investigating this issue.
Posted Sep 28, 2022 - 07:26 EDT
This incident affected: Transportation (Bus 16).