Bus #22 - Sub Driver - Expect possible delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Jan 12, 2022 - 17:31 EST
Update
We are continuing to investigate this issue.
Posted Jan 12, 2022 - 13:53 EST
Investigating
We are currently investigating this issue.
Posted Jan 11, 2022 - 13:13 EST
This incident affected: Transportation (Bus 22).