Bus #36 and Bus #1 will be combined this afternoon for all schools. Bus #36 2 loads for Elem and load 3 will be bus 1
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 15, 2024 - 05:39 EDT
Update
We are continuing to investigate this issue.
Posted Apr 12, 2024 - 12:42 EDT
Update
We are continuing to investigate this issue.
Posted Apr 12, 2024 - 12:41 EDT
Investigating
We are currently investigating this issue.
Posted Apr 12, 2024 - 12:39 EDT
This incident affected: Transportation (Bus 01, Bus 36).