Bus 9 CMS/CHS will be split between Bus 34, 16, 12, expect delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Oct 04, 2022 - 09:14 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 04, 2022 - 05:57 EDT
This incident affected: Transportation (Bus 09, Bus 16, Bus 34, Bus 12).