Bus 47 will be a 2nd load on bus 6 for CMS (Possible Delays) 10/23/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Oct 24, 2025 - 05:37 EDT

Monitoring

Bus 6 will be 1st load

Bus 47 will be 2nd load
Posted Oct 23, 2025 - 13:45 EDT
This incident affected: Transportation (Bus 06, Bus 47).