Bus 15 will split between buses 11 & 52 for Bethany, CMS & CHS (Expect Delays) 10/18/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Oct 18, 2024 - 17:55 EDT
Monitoring
Sherwood Rd, Crestland & Bowling Green Dr will ride bus 11
The rest of 15 will ride bus 52
Posted Oct 18, 2024 - 14:05 EDT
This incident affected: Transportation (Bus 11, Bus 15, Bus 52).