Bus 6 will be a 2nd load on Bus 4 for CMS (Possible Delays) 10/20/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 06:15 EDT

Monitoring

Bus 4 will be 1st load
Bus 6 will be 2nd load
Posted Oct 20, 2025 - 14:09 EDT
This incident affected: Transportation (Bus 04, Bus 06).