Bus 29 = Permanent change to Bus 31 & Sub Driver, possible delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Sep 28, 2022 - 17:14 EDT
Update
We are continuing to monitor for any further issues.
Posted Sep 28, 2022 - 13:23 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2022 - 13:21 EDT
This incident affected: Transportation (Bus 29).