Bus 6, 15 & 28 has a sub driver (Possible Delay) 8/28/2024
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Aug 29, 2024 - 06:50 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 28, 2024 - 13:55 EDT
This incident affected: Transportation (Bus 06, Bus 15, Bus 28).