The following bus will be combined for CHS (Possible Delays) 3/3/26

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 18:05 EST

Monitoring

Buses 14 & 29 will be combined on bus 14
Buses 37 & 41 will be combined on bus 41
Buses 57 & 61 will be combined on bus 47
Posted Mar 03, 2026 - 14:13 EST
This incident affected: Transportation (Bus 14, Bus 29, Bus 37, Bus 41, Bus 47, Bus 61).