Bus #24 = Sub Driver, possible delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted May 18, 2022 - 17:12 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 18, 2022 - 13:07 EDT
This incident affected: Transportation (Bus 24).