Bus #14 is on Bus#203 Is on Schedule for High School
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Nov 29, 2021 - 09:21 EST
Update
We are continuing to investigate this issue.
Posted Nov 29, 2021 - 08:11 EST
Update
We are continuing to investigate this issue.
Posted Nov 29, 2021 - 07:30 EST
Update
We are continuing to investigate this issue.
Posted Nov 29, 2021 - 06:29 EST
Investigating
We are currently investigating this issue.
Posted Nov 29, 2021 - 06:12 EST
This incident affected: Transportation (Bus 14).