Buses 12 & 29 will be combined on bus 29 for GRES (Possible Delays) 2/5/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Feb 06, 2025 - 05:26 EST

Monitoring

Bus 29 will be 1st load
Bus 12 will be 2nd load
Posted Feb 05, 2025 - 13:14 EST
This incident affected: Transportation (Bus 12, Bus 29).