Bus 14 CHS = with Bus 12, expect delays
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Oct 03, 2022 - 17:50 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 03, 2022 - 14:17 EDT
This incident affected: Transportation (Bus 14, Bus 12).