Bus 4 & 6 are combined on bus 4 for KES & Bus 13 for CMS, CHS/NGC (Possible Delays) 8/29/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Aug 29, 2024 - 09:25 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 29, 2024 - 06:57 EDT
This incident affected: Transportation (Bus 04, Bus 06, Bus 13).