Bus 10 will be split between buses 4 & 6 for KES (Possible Delays) 4/3/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Apr 03, 2025 - 09:23 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 03, 2025 - 06:30 EDT
This incident affected: Transportation (Bus 04, Bus 06, Bus 10).