Buses 14 & 22 are combined on bus 14 for GES, CMS & CHS/NGC (Possible Delays) 4/10/24
Incident Report for Clover School District
Resolved
This incident has been resolved.
Posted Apr 17, 2024 - 09:17 EDT
Monitoring
Students who live on Ormand Rd will ride bus 9 for CMS & CHS/NGC
Posted Apr 17, 2024 - 06:19 EDT
This incident affected: Transportation (Bus 09, Bus 14, Bus 22).