Expect Delay: Bus 47 is running about 15 minutes behind 4/11/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Apr 11, 2025 - 10:16 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 11, 2025 - 06:57 EDT
This incident affected: Transportation (Bus 47).