External Calls issues

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted May 07, 2026 - 16:11 EDT

Investigating

We are actively investigating the cause of the issues affecting external calls. We will provide further updates as soon as more information becomes available.
Posted May 07, 2026 - 08:34 EDT
This incident affected: Internet & Telephony Services (Bethany Elementary, Bethel Elementary, Crowders Creek Elementary, Griggs Road Elementary, Kinard Elementary, Larne Elementary, Oakridge Elementary, Clover Middle, Oakridge Middle, Resource Center & Blue Eagle Academy, Ninth Grade Campus, Clover High, Technology Warehouse, Maintenance, District Office).