Buses 26 & 56 will be combined on bus 56 for OMS (Possible Delays) 8/21/25

Incident Report for Clover School District

Resolved

This incident has been resolved.
Posted Aug 21, 2025 - 21:11 EDT

Monitoring

Bus 56 will be 1st load
Bus 26 will be 2nd load
Posted Aug 21, 2025 - 13:29 EDT
This incident affected: Transportation (Bus 26, Bus 56).